(!) Как настроить OSPF на Ethernet-коммутаторах ZyXEL 3-го уровня?

Как настроить функцию OSPF на Ethernet-коммутаторах ZyXEL 3-го уровня?


В данной статье описан протокол «предпочтения кратчайшего пути» OSPF (Open Shortest Path First) и описан порядок настройки OSPF.


Обзор протокола OSPF


Протокол «предпочтения кратчайшего пути» OSPF представляет собой протокол маршрутизации по состоянию канала, предназначенный для распространения информации о маршрутах в пределах автономной системы (AS). Под автономной системой понимается группа сетей, использующих общий протокол маршрутизации для обмена информацией о маршрутах.


Автономная система OSPF может быть разделена на логические области. Каждая область представляет группу смежных сетей. Все области подключаются к магистрали (также называемой областью 0). Магистраль представляет собой транзитную область для маршрутизации пакетов между двумя областями. Тупиковая область на границе автономной системы не является транзитной областью, так как к ней имеется только одно подключение.
Четыре класса маршрутизаторов OSPF описаны в следующей таблице.


ТИП ОПИСАНИЕ
Внутренний маршрутизатор (IR) Внутренним или внутриобластным маршрутизатором называется маршрутизатор в области.
Граничный маршрутизатор области (ABR) Граничный маршрутизатор области подключается к двум или нескольким областям.
Магистральный маршрутизатор (BR) Магистральный маршрутизатор имеет интерфейс к магистрали.
Граничный маршрутизатор автономной системы Граничный маршрутизатор автономной системы обменивается информацией о маршрутах с другими автономными системами.

Пример сети OSPF показан на следующем рисунке. Магистраль находится в области 0 с магистральным маршрутизатором. Внутренние маршрутизаторы находятся в области 1
и области 2. Граничные маршрутизаторы области подключают области 1 и 2 к магистрали.



Как работает протокол OSPF


Устройства уровня 3 обмениваются информацией о маршрутах для построения синхронизированной базы данных состояний каналов в рамках одной автономной системы или одной области. Для этого они обмениваются сообщениями Hello, чтобы подтвердить наличие соседних устройств (уровня 3), а затем – описаниями базы данных (DD), позволяющими построить базу данных состояний каналов. База данных состояний каналов непрерывно обновляется посредством объявлений о состоянии канала LSA (Link State Advertisement). База данных состояний каналов содержит записи, которые включают в себя идентификаторы маршрутизаторов, связанные с ним каналы и стоимости путей. Каждое из устройств может использовать базу данных состояний каналов и алгоритм Дейкстра для вычисления путей к пунктам назначения в сети с наименьшей стоимостью.


Настройка OSPF


Чтобы настроить на коммутаторе протокол OSPF, необходимо выполнить следующие задачи:
1 Включить протокол OSPF
2 Создать области OSPF
3 Создать и связать интерфейсы с областью
4 Создать виртуальные каналы для поддержания связности с магистралью.
 


Маршрутизатор или коммутатор 3-го уровня, принадлежащие двум областям, называют граничным маршрутизатором области (ABR). Область Area 0.0.0.0 называется магистральной областью (Backbone Area), которая соединяет все остальные, немагистральные области. В нашем примере, область Area 0.0.0.0 соединяет область Area 0.0.0.1 и область Area 0.0.0.2. Коммутаторы Switch B и Switch C находятся на границе между двумя областями, в результате чего Switch B и Switch C становятся граничными маршрутизаторами области.



Рассматривается следующая топология:



Два коммутатора 3-го уровня Switch A и Switch B соединены с двумя разными подсетями. Коммутаторы будут просматривать на 3-м уровне информацию, например IP-заголовок, и пересылать пакеты согласно таблице маршрутизации. Однако сначала нужно запустить протокол маршрутизации на обоих коммутаторах, т.к. оба коммутатора не имеют ни малейшего представления о подсетях соседнего.



Коммутатор Switch A не знает, как маршрутизировать пакеты в подсеть 192.168.10.0/24, а коммутатор Switch B не знает, как маршрутизировать пакеты в подсеть 192.168.5.0/24. Для этого нужно запустить протокол OSPF на обоих коммутаторах.



Записи, отмеченные красным в таблице маршрутизации, коммутаторы узнали через протокол маршрутизации OSPF. После того как на обоих коммутаторах статус Neighbor - FULL в OSPF-сети, это означает, что оба коммутатора узнали состояние канала соседнего коммутатора и рассчитаны лучшие маршруты. Два хоста из разных подсетей теперь могут осуществлять передачу пакетов друг другу. В этом случае коммутаторы Switch A и Switch B смогут пересылать пакеты в подсеть другого коммутатора.


Настройка с использованием веб-конфигуратора (Switch A)

1. Подключите порт MGMT к компьютеру Ethernet-кабелем.
2. По умолчанию на порту MGMT IP (адрес для управления вне полосы пропускания) - 192.168.0.1/24.
3. Установите на вашем сетевом адаптере IP-адрес - 192.168.0.100/24.
4. Откройте браузер (например, Internet Explorer) и  введите http://192.168.0.1 в поле Адрес.
5. По умолчанию имя пользователя (username) для администратора - admin и пароль (password) - 1234.
6. После успешной авторизации вы увидите экран, как показано ниже.



7. Сначала нужно создать два VLAN'а для двух разных доменов маршрутизации. Нажмите Advanced Application > VLAN > Static VLAN.



8. Создайте VLAN 2 и включите Port 1 в этот VLAN, нажмите Add.



9. Создайте VLAN 3 и включите Port 2 в этот VLAN, нажмите Add.



10. Перейдите на страницу VLAN Port Setting.



Установите на Port 1 - PVID 2 и на Port 2 - PVID 3. Нажмите Apply.



11. Перейдите на страницу IP Setup нажав Basic Setting > IP Setup.



12. В разделе IP Interface установите IP-адрес (IP Address), Маску подсети (IP Subnet Mask) и VID для VLAN 2. Нажмите Add.



13. В разделе IP Interface установите IP-адрес (IP Address), Маску подсети (IP Subnet Mask) и VID для VLAN 3. Нажмите Add.



14. Перейдите на страницу OSPF Configuration, нажав IP Application > OSPF > Configuration.



15. Убедитесь, что в поле Active установлена галочка, т.е. включен протокол маршрутизации OSPF и установлен Router ID. Router ID должен быть любой 32-битный IP-адрес. Нажмите Apply.



16. Введите в поле Name название (до 32 символов ASCII). Создайте область 0.0.0.0 в поле Area ID. Нажмите Add.



17. Перейдите на страницу OSPF Interface, нажав Interface.



18. На странице OSPF Interface выберите в поле Network IP-интерфейс, который будет присоединен к маршрутизации OSPF, и в поле Area ID область, к которой этот IP-интерфейс принадлежит. Нажмите Add.




19. Теперь маршрутизирующий протокол OSPF на коммутаторе Switch A будет запущен, и можно начать настройку коммутатора Switch B.


Настройка с использованием веб-конфигуратора (Switch B)

1. Подключите порт MGMT к компьютеру Ethernet-кабелем.
2. По умолчанию на порту MGMT IP (адрес для управления вне полосы пропускания) - 192.168.0.1/24.
3. Установите на вашем сетевом адаптере IP-адрес - 192.168.0.100/24.
4. Откройте браузер (например, Internet Explorer) и введите http://192.168.0.1 в поле Адрес.
5. По умолчанию имя пользователя (username) для администратора - admin и пароль (password) - 1234.
6. После успешной авторизации вы увидите экран, как показано ниже.



7. Сначала нужно создать два VLAN'а для двух разных доменов маршрутизации. Нажмите Advanced Application > VLAN > Static VLAN.



8. Создайте VLAN 2 и включите Port 1 в этот VLAN, нажмите Add.



9. Создайте VLAN 3 и включите Port 2 в этот VLAN, нажмите Add.



10. Перейдите на страницу VLAN Port Setting и установите на Port 1 - PVID 2 и на Port 2 - PVID 3. Нажмите Apply.




11. Перейдите на страницу IP Setup нажав Basic Setting > IP Setup.



12. В разделе IP Interface установите IP-адрес (IP Address), Маску подсети (IP Subnet Mask) и VID для VLAN 2. Нажмите Add.



13. В разделе IP Interface установите IP-адрес (IP Address), Маску подсети (IP Subnet Mask) и VID для VLAN 3. Нажмите Add.



14. Перейдите на страницу OSPF Configuration, нажав IP Application > OSPF > Configuration.



15. Убедитесь, что в поле Active установлена галочка, т.е. маршрутизирующий протокол OSPF включен и установлен Router ID. Router ID должен быть любой 32-битный IP-адрес. Нажмите Apply.



16. Введите в поле Name название (до 32 символов ASCII). Создайте область 0.0.0.0 в поле Area ID. Нажмите Add.



17. Перейдите на страницу OSPF Interface, нажав Interface.



18. На странице OSPF Interface выберите в поле Network IP-интерфейс, который будет присоединен к маршрутизации OSPF, и в поле Area ID область, к которой этот IP-интерфейс принадлежит. Нажмите Add.




Настройка OSPF с использованием командного интерфейса (Switch A)








vlan 1
name 1
normal
fixed 1-28
forbidden
untagged 1-28
ip address 192.168.1.1 255.255.255.0
exit
vlan 2
normal 2-28
fixed 1
forbidden
untagged 1
ip address 192.168.5.1 255.255.255.0
exit
vlan 3
normal 1,3-28
fixed 2
forbidden
untagged 2
ip address 192.168.2.1 255.255.255.0
exit
router ospf 10.1.1.1
area 0.0.0.0
area 0.0.0.0 name name
network 192.168.2.1/24 area 0.0.0.0
network 192.168.5.1/24 area 0.0.0.0
interface port-channel 1
pvid 2
exit
interface port-channel 2
pvid 3
exit
interface route-domain 192.168.1.1/24
exit
interface route-domain 192.168.2.1/24
exit
interface route-domain 192.168.5.1/24
exit
ip address 192.168.0.1 255.255.255.0

Настройка OSPF с использованием командного интерфейса (Switch B)








vlan 1
name 1
normal
fixed 1-28
forbidden
untagged 1-28
ip address 192.168.1.1 255.255.255.0
exit
vlan 2
normal 2-28
fixed 1
forbidden
untagged 1
ip address 192.168.10.1 255.255.255.0
exit
vlan 3
normal 1,3-28
fixed 2
forbidden
untagged 2
ip address 192.168.2.2 255.255.255.0
exit
router ospf 10.1.1.2
area 0.0.0.0
area 0.0.0.0 name name
network 192.168.2.2/24 area 0.0.0.0
network 192.168.10.1/24 area 0.0.0.0
exit
interface port-channel 1
pvid 2
exit
interface port-channel 2
pvid 3
exit
interface route-domain 192.168.1.1/24
exit
interface route-domain 192.168.2.2/24
exit
interface route-domain 192.168.10.1/24
exit
ip address 192.168.0.1 255.255.255.0
 

KB-1827

Была ли эта статья полезной?
Пользователи, считающие этот материал полезным: 0 из 0